This forum is closed for posting. Please, join us in our Discord server at discord.gg/regnum. See you there!

Go Back   Champions of Regnum > Testing server (Amun) > Old versions

Old versions Archived posts from old versions.

 
 
Thread Tools Display Modes
Old 07-13-2009, 11:42 AM   #1
Zas_
Count
 
Zas_'s Avatar
 
Join Date: Jun 2009
Location: France
Posts: 1,024
Zas_ is on a distinguished road
Default [BUG] run/walk is often interrupted by camera move

It occurs for example when in autorun, and changing camera position using mouse.
It doesn't occur in 1.0.6.
__________________
Annavilya / War-Luck (Haven)
Zas_ no ha iniciado sesión  
Old 07-13-2009, 02:38 PM   #2
Znurre
Marquis
 
Join Date: Jan 2007
Location: RA
Posts: 1,897
Znurre will become famous soon enoughZnurre will become famous soon enough
Default

This happens for me right after a fresh login, when using mouselook.
The solution is to release all mouse buttons and click somewhere in the Regnum window that is not covered by the UI.

After this, you should not have the problem until a relog/character change.

Really weird bug.
__________________
Winning a fight is not what makes you a good player, it's how you do it.
http://home.znur.re/screenshot%20201...2011_39_37.jpg
Znurre no ha iniciado sesión  
Old 07-15-2009, 08:24 AM   #3
NaturalBornKiller
Apprentice
 
NaturalBornKiller's Avatar
 
Join Date: Nov 2008
Location: Waste Lands
Posts: 75
NaturalBornKiller is on a distinguished road
Default

If the problem is what I think, then it's about your keyboard, not about the game, try to change the movement keys from 'wasd' to for example 'rdfg' and the problem is gone for me.

That's why on Quake i usually play with rdfg... it's an old problem on the rpgs :P

In my case the problem was that if I use mouse look while holding forward + strafe and then leave the strafe key the 'forward' wasn't anymore active while I still was pressing it.
__________________
The man in black fled across the desert and the gunslinger followed.
NaturalBornKiller no ha iniciado sesión  
Old 07-15-2009, 11:30 AM   #4
Zas_
Count
 
Zas_'s Avatar
 
Join Date: Jun 2009
Location: France
Posts: 1,024
Zas_ is on a distinguished road
Default

Quote:
Originally Posted by Outlaw_ View Post
If the problem is what I think, then it's about your keyboard, not about the game, try to change the movement keys from 'wasd' to for example 'rdfg' and the problem is gone for me.

That's why on Quake i usually play with rdfg... it's an old problem on the rpgs :P

In my case the problem was that if I use mouse look while holding forward + strafe and then leave the strafe key the 'forward' wasn't anymore active while I still was pressing it.
Why should 'wasd' to 'rdfg' be related to this bug ?
I tested, no change, same issue.
It is related on how keys/mouse events are handled imho.
__________________
Annavilya / War-Luck (Haven)
Zas_ no ha iniciado sesión  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved